RB

Login-Schleife / Registry "flicken"

Windows XP Betriebssystem der Firma Microsoft. XP steht dabei für „eXPerience“ (engl. für Erfahrung, Erlebnis).

Moderator: PC-Special Members

Login-Schleife / Registry "flicken"

Beitragvon baumkraxler » Fr Feb 04, 2011 8:18 am

Hallo,

jetzt habe ich schon viel selbst gesucht und geschafft, komme aber ohne gute Hilfe nicht mehr weiter.
Der PC meiner Freundin hatte Viren. Die sind jetzt weitestgehend weg. Allerdings habe ich im Zuge der Reinigung am Ende wohl übertrieben...
...ein Virenscanner nannte einen Registry-Eintrag gefährlich, den ich daraufhin geändert habe (um ihn für das betr. Programm unsichtbar zu machen).

Es handelte sich um einen Eintrag betreffend userinit . Seitdem hängt der Rechnder am Login: Es erscheint kurz der korrekte Desktophintergrund, allerdings ohne Icons, dann wird der Benutzer wieder abgemeldet, man landet wieder am Login-Screen. Die Meldungen sind dabei wie sonst ("...wird angemeldet...", "...wird abgemeldet").
Also habe ich den Rechner zu mir genommen, habe also Zugriff auf die Platte, da sie extern an meinem Rechner hängt; Daten sind gesichert und nochmal drei Virenscanner drüberlaufen lassen.

Nun habe ich bisher soviel gelernt:
userinit ist eine von XP beim Login benötigte Datei.
Die Einzelteile der Registry sind u.A. in WINDOWS\system32\config gespeichert.
Ich habe aus WINDOWS\repair\ die "software" - Datei in den WINDOWS\config - Ordner verschoben (daraus zieht XP dann Daten für die Registry), und siehe da, der Rechner startet. Mit folgendem Phänomen:
Am Login-Bildschirm erscheinen die drei bekannten User, jeweils mit dem Icon wie vorher.
Logge ich mich ein, erzeugt XP einen neuen User, Namens "Username\Rechnername"
Die meisten vorhandenen Programme sind nicht installiert, der Rechner ist auf einem Stand wie vor Jahren.

Ich habe dann eine vorher gesicherte Registry geladen, in der Hoffnung, XP würde die software - Datei in WINDOWS\system32\config entsprechend aktualisieren, das geschah aber leider nicht.
Auch die Systemwiederherstellungspunkte findet XP leider nicht mehr.

Wer kann mir weiterhelfen? Ich kann im Moment zwischen einem System wählen das startet, aber unbrauchbar ist, weil es auf einem Stand vor 4 Jahren ist, und einem, das aktuell ist, aber leider keinen Login zulässt.

Gibt es Programme, mit denen die Dateien in ...\system32\config editierbar sind (wordpad und editor zeigen zu viele Hyroglyphen und lassen kein kopieren zu)?
Eine Möglichkeit, einen der vorhandenen aber nicht erkannten Systemwiederherstellungspunkte zu aktivieren?
Oder einfach den Login zu erzwingen?

Ich wäre über Hilfe sehr erfreut und dankbar!

Frank
baumkraxler
Frischling
Frischling
 
Beiträge: 4
Registriert: Fr Feb 04, 2011 7:45 am
Betriebssystem: Windows XP
Browser: Mozilla Firefox
Internet-Verbindung: ISDN
Mainboard: Asus
Prozessor: Intel
Arbeitsspeicher: 1 GB
Grafikkarte: onboard
Festplatte: Seagate Barracuda 160 GB
Postleitzahl: 85625
Land: Germany

Re: Login-Schleife / Registry "flicken"

Beitragvon HapHazard » Fr Feb 04, 2011 11:48 am

Hi..
also ehrlich gesagt sieht es für mich so aus, als hättest du den PC bereits zurückgesetzt. Einige Dinge sind schon defekt oder zerstört. Ein Neuaufsetzen würde da sicherlich alles wieder sauber hinbiegen, aber dann muss natürlich alles neu gemacht werden.

Du kannst aber die Windows-Reparaturinstallation mal durchführen. Dabei sollten einige Dinge behoben werden. Hast du denn mal den abgesicherten Modus mal hochgefahren und geschaut wie er sich dort verhält ? Dafür solltest du allerdings den PC auch vor Ort haben und nicht nur die Platte. So alleine bringt dir das nichts.

Gruß
Hap
HapHazard
PC-Special Member
PC-Special Member
 
Beiträge: 2080
Registriert: Do Mär 09, 2006 2:26 pm
Wohnort: bei Hannover
Betriebssystem: Windows 7
Browser: Mozilla Firefox
Internet-Verbindung: DSL/Kabel ab 2MB/s
Mainboard: Gigabyte P67A-UD5-B3
Prozessor: Intel i7-2600k@3,8 GHz
Arbeitsspeicher: 32 GB DDR3 1600
Grafikkarte: Gainward GTX 670
Festplatte: SSD, Raid5 + HDDs
Postleitzahl: 30890
Land: Germany

Re: Login-Schleife / Registry "flicken"

Beitragvon baumkraxler » Fr Feb 04, 2011 2:58 pm

Hallo Hap,

die Reparaturinstallation macht auch alles platt, weil sie mit SP3 nicht klarkommt, das nachträglich dazukam.
Ich habe den Rechner auch hier, bin dauernd am Wechseln der Platte. Im abgesicherten Modus ist es das Gleiche, auch in allen anderen Modi die mit F8 startbar sind.

Ich habe natürlich auch daran gedacht, den Rechner neu aufzustezen. Es ist nur... so beinahe greifbar: Eine "software" mit 8MB startet, eine andere "software" mit 27MB hat sämtliche Informationen, startet nur nicht.
Beide sind verfügbar, aber es gibt kein Tool, sie zu editieren, oder den Defekt in der aktuellen zu reparieren.

Es ist womöglich doch nicht die Änderung des Eintrages userinit verantwortlich, dieser liest sich (mit WordPad zwischen den Hyroglyphen) eigentlich korrekt.

Kann man evtl. die Systemwiederherstellung "manuell" starten? Gibt es Information, wo dort die "software"-Datei gespeichert ist, und wie, bnzw. vor allem wie zugänglich?
Es würde wahrscheinlich ausreichen, diese wieder herzustellen. Die Systemwiederherstellungsdateien sind sämtlich vorhanden, nur weiß das startende System nichts von ihnen.

Gerne Gruß zurück,

Frank
baumkraxler
Frischling
Frischling
 
Beiträge: 4
Registriert: Fr Feb 04, 2011 7:45 am
Betriebssystem: Windows XP
Browser: Mozilla Firefox
Internet-Verbindung: ISDN
Mainboard: Asus
Prozessor: Intel
Arbeitsspeicher: 1 GB
Grafikkarte: onboard
Festplatte: Seagate Barracuda 160 GB
Postleitzahl: 85625
Land: Germany

Re: Login-Schleife / Registry "flicken"

Beitragvon pia.dk » Mo Feb 07, 2011 12:34 pm

Manuelles Starten der Systemwiederherstellung:
"Zugreifen auf die Systemwiederherstellung
Sie müssen Mitglied der Gruppe Administratoren für den Computer sein, um auf den Systemwiederherstellungs-Assistenten zugreifen oder die Einstellungen der Systemwiederherstellung ändern zu können.

Für den Zugriff auf die Funktionen der Systemwiederherstellung stehen drei Methoden zur Verfügung.

Sie können über das Startmenü auf den Systemwiederherstellungs-Assistenten zugreifen. Zeigen Sie zum Öffnen des Systemwiederherstellungs-Assistenten im Startmenü auf Programme, zeigen Sie auf Zubehör, zeigen Sie auf Systemprogramme, und klicken Sie dann auf Systemwiederherstellung.
Sie können über die Systemsteuerung auf Systemwiederherstellung zugreifen. Zeigen Sie zum Öffnen des Systemwiederherstellungs-Assistenten im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, und doppelklicken Sie dann auf System. Klicken Sie auf die Registerkarte Systemwiederherstellung, und klicken Sie dann auf Weitere Informationen zur Systemwiederherstellung. Klicken Sie unter Hilfe und Support auf Leistung und Wartung, klicken Sie auf Verwenden der Systemwiederherstellung zum Rückgängigmachen von Änderungen, und klicken Sie dann auf Ausführen des Systemwiederherstellungs-Assistenten.
Sie können über das Hilfe- und Supportcenter auf Systemwiederherstellung zugreifen. Klicken Sie zum Öffnen des Systemwiederherstellungs-Assistenten im Startmenü auf Hilfe und Support. Klicken Sie auf Leistung und Wartung, klicken Sie auf Verwenden der Systemwiederherstellung zum Rückgängigmachen von Änderungen, und klicken Sie dann auf Ausführen des Systemwiederherstellungs-Assistenten. "
Vielleicht findest Du so einen funktionierenden Wiederherstellungspunkt.
pia.dk
Frischling
Frischling
 
Beiträge: 30
Registriert: Fr Jul 25, 2008 11:46 am
Postleitzahl: 53474
Land: Germany

Re: Login-Schleife / Registry "flicken"

Beitragvon baumkraxler » Di Feb 08, 2011 11:22 am

Hallo pia.dk,

Danke für die Unterstützung, aber auf diesem Weg komme ich nicht "ran".

Die Registry mit den Systemwiederherst.punkten ist nicht startfähig.
Die startfähige Registry kennt die Syst.wdhst.punkte nicht.

Was ich bräuchte wäre etwas wie z.B. ein Kommandozeilenbefehl "stelle Systempunkt -Verzeichnis -Dateiname wieder her", wenn es so etwas gibt. Und die Information, wo XP die Systemwdh.st.punkte speichert und in welcher Form.

Ich freunde mich gerade gedanklich mit einem Neuaufsetzen an, wenn aber noch Hilfe kommt, probiere ich gerne noch etwas aus.

Vielen Dank,

Frank
baumkraxler
Frischling
Frischling
 
Beiträge: 4
Registriert: Fr Feb 04, 2011 7:45 am
Betriebssystem: Windows XP
Browser: Mozilla Firefox
Internet-Verbindung: ISDN
Mainboard: Asus
Prozessor: Intel
Arbeitsspeicher: 1 GB
Grafikkarte: onboard
Festplatte: Seagate Barracuda 160 GB
Postleitzahl: 85625
Land: Germany

Re: Login-Schleife / Registry "flicken"

Beitragvon Backgammon_128 » Do Feb 10, 2011 6:31 pm

Wenn du mit einem anderen System selbst an die Festplatte kommst, um dort Daten zu bearbeiten, dann hilft vielleicht das

http://support.microsoft.com/kb/307545

oder man holt sich aus einem Systemwiederherstellungspunkt im Systemvolume Information-Ordner die 5 Dateien der Registry und spielt diese zurück. Vorher natürlich die anderen Dateien deaktivieren (also in xxxx.bak) umbenennen

system
software
sam
security
default




Gruß
Back
Beschwerden über Schreibfehler, fehlende Buchstaben oder Leerzeichen bitte an meine Tastatur richten.

Frau Tasta Tur
Musterstrasse 11
11111 Musterstadt

Bitte verratet nicht, dass ich sie angeschmiert hab, sonst wird das alte Luder noch sauer. ;)
Backgammon_128
PC-Specialist
PC-Specialist
 
Beiträge: 6817
Registriert: Do Mär 11, 2004 3:55 pm
Betriebssystem: Windows XP
Browser: Mozilla Firefox
Internet-Verbindung: DSL/Kabel ab 2MB/s
Postleitzahl: 0
Land: Germany

Re: Login-Schleife / Registry "flicken"

Beitragvon baumkraxler » Do Feb 17, 2011 6:02 pm

Vielen Dank für eure Hilfe,

leider war die Anzahl vorhandener Systemwiederherstellunkspunkte mit "Snap-In"-Ordner (in dem die Registry-Dateien sind) nicht ausreichend... bzw. nicht brauchbar.

Mittlerweile habe ich den Rechner neu aufgesetzt, was ja auch was Schönes hat.

Alles Gute und Ruhe in unruhigen Zeiten,

Frank
baumkraxler
Frischling
Frischling
 
Beiträge: 4
Registriert: Fr Feb 04, 2011 7:45 am
Betriebssystem: Windows XP
Browser: Mozilla Firefox
Internet-Verbindung: ISDN
Mainboard: Asus
Prozessor: Intel
Arbeitsspeicher: 1 GB
Grafikkarte: onboard
Festplatte: Seagate Barracuda 160 GB
Postleitzahl: 85625
Land: Germany


RB


Zurück zu Windows XP



Ähnliche Beiträge

Wer ist online?

Mitglieder in diesem Forum: pletchermaj und 18 Gäste